Canon LIDE Scanner and Printer Driver for Microsoft Windows 7 64-bit

Sponsored Links

One of the problem I faced what the incompatibility of my Canon LIDE Scanner driver with Windows 7 64 bit, for some unknown reasons, the CanoScan LiDE 25, 30, 35, 60, 70, 90, 100, 200 driver in Canon’s official website does not work. Here is the solution for those having problem installing their Canon PIXMA printer, Bublejet printer, Inkjet printer and LIDE scanner driver for Windows 7.

All you have to do is look for the driver in Windows 7 itself.

Canon LIDE Scanner and Printer Driver for Microsoft Windows 7 64-bit

Step 1 – Right click ‘My Computer’
Step 2 – Click on ‘Device Manager’
Step 3 – Under the ‘Other Devices’ list, right click ‘Cano Scan’
Step 4 – Select ‘Properties’

Canon LIDE Scanner And Printer Driver For Microsoft Windows 7 64-bit

Step 5 – A new window will appear, select the ‘Driver’ tab
Step 6 – Click on the ‘Update Driver’ button
Step 7 – Choose ‘ Browse my computer for driver software’

Canon LIDE Scanner and Printer Driver for Microsoft Windows 7 64-bit

Step 8 – Select the ‘Let me pick from a list of device…’ link

Canon LIDE Scanner and Printer Driver for Microsoft Windows 7 64-bit

Step 9 – Look for ‘Canon Inc’ under the manufacturer list
Step 10 – Select CanoScan LiDE 60

Download Canon LIDE Driver

DelDrv Ver. 2.4.64.0 (Windows 7 x64/Vista64/XP x64) for Microsoft Windows 7 (x64), Windows Vista (x64) and Windows XP (x64). CanoScan LiDE 60 driver is compatible with all LiDE 25, 30, 35, 60, 70, 90, 100, 200 and many more. It works with my LiDE 35. Copy and paste link from the official Canon website:

http://pdisp01.c-wss.com/gdl/WWUFORedirectTarget.do?id=MDkwMDAwMjk1MzAx&cmp=ACB&lang=EN

34 comments on “Canon LIDE Scanner and Printer Driver for Microsoft Windows 7 64-bit

  1. Offsprung October 4, 2010 at 8:07 am - Reply

    You do realize there is NO CanoScan in “Windows 7 itself”. My guess is from your pics YOU installed it in CanoScan Lite 35\SetupSG LIDE60. Yet to find one that actually works. You conclusions are very incorrect.

    • GeckoFly October 4, 2010 at 4:45 pm - Reply

      I assumed that you’re using Windows 7 32-bit Home Edition. I am using Windows 7 64-bit Home Premium.

      • Peter November 8, 2010 at 11:27 pm - Reply

        Iam also using Windows 7 64-bit Home Premium edition and i also didnt found driver in windows database :-(

        • GeckoFly November 8, 2010 at 11:37 pm - Reply

          Select LiDE60 even if you own a LiDE 20/25/30/50. Coz the LiDE60 driver works on all model

  2. derausgewanderte January 17, 2011 at 12:34 pm - Reply

    have latest windows 7 64bit. all I see is LiDE25 in that list because it automatically installed that driver. However, that’s not working. thought I give your solution a try, but the LiDE is not listed there. Probably have to download and install the specific driver to get it populated in that list.
    thanks

  3. malik February 9, 2011 at 2:09 pm - Reply

    send me a driver lide25

  4. Max February 12, 2011 at 1:39 am - Reply

    To clarify the post:
    The X64 Lide 60 driver is not distributed with Windows.
    The X64 Lide 60 driver can be downloaded from the official Canon site. Then you have to extract it (not install it!) using 7zip for instance. You will be able to browse to this file.

    I tried this solution on my Windows 7 64 bit for my Lide 30 and it did not work.

    • Andrey April 24, 2011 at 3:43 pm - Reply

      Send to me please DRIVER Lide 30, Windows 7 64 bit.

  5. Stuart Drabble May 19, 2011 at 4:54 pm - Reply

    Actually, I suspect many of you are having issues because of the difference between older, TWAIN scanners, and newer, WIA scanners.

    My LiDE 25 drivers a fully installed but WIA aware applications are not picking up the scanner t all. There is meant to be an overlap between the two standards, but there are still issues.

    • GeckoFly May 19, 2011 at 9:10 pm - Reply

      Prossibly, maybe the model am using is different from other therefore the solution I wrote is not applicable to others.

  6. Marion June 16, 2011 at 9:05 pm - Reply

    The one that works with my lide50 /windows7 64 bit is:
    lide60vst6411111a_64nl
    http://software.canon-europe.com/software/0027682.asp?model=

    Good luck with it and thanks a lot for the clear explanation :-)))))))))))))

  7. vijay July 29, 2011 at 10:23 am - Reply

    Difficulty some of downloading driver

  8. me January 4, 2012 at 6:30 pm - Reply

    Lide 60 driver does not work for lide 25. I tried it

    • eby April 15, 2013 at 4:41 pm - Reply

      LiDE 110 Scanner Driver for Windows 8(64bit)

  9. Darryl March 7, 2012 at 4:54 pm - Reply

    I been working on this for weeks now, even if you updated the LIDE 30 with the LIDE 60 drivers and install an older version on Canon Toolbox it doesn’t work. Seems to work with a lot of scanners after LIDE 30, BUT NOT WITH LIDE 20/30.

  10. Eviler March 28, 2012 at 10:13 pm - Reply

    Has anyone tried this with a Canon Lide 80? Thanks.

  11. komok August 13, 2012 at 6:47 am - Reply

    lide60vst6411111a_64en.exe win 7 :
    http://depositfiles.com/files/wj6erzpqf

    canon_tools.exe:
    http://depositfiles.com/files/kz9qkyczv

  12. aced October 6, 2012 at 2:25 am - Reply

    Send to me please DRIVER Lide 20, Windows 7 64 bit.

  13. James October 27, 2012 at 8:57 pm - Reply

    To get the Canon CanoScan LiDE 25 working on Windows 8 64bit (and I’m assuming Windows 7 64bit as well), I downloaded the WIA Vista 64 bit driver called lide25wiavst641210en.exe (note the “wia” in the filename) from the canon website.

    • tempuser June 1, 2013 at 6:42 am - Reply

      this vista wia driver worked for me too, thanks!

      • Geckoandfly June 1, 2013 at 4:02 pm - Reply

        @tempuser

        Glad that this tutorial helps, thanks for visiting our blog. cheers

  14. Mohammad January 29, 2013 at 7:17 am - Reply

    This link for torrent work with me 100%

  15. Luxan February 6, 2013 at 5:38 am - Reply

    What a shame that Canon expects us to dump our lide scanners because Canon refuses to provide the driver/software needed for newer OS like win7-64. Is Canon waiting for a class action law suit? Maybe we should swarm canon and the web with complaints about such arrogance.

  16. ferran February 13, 2013 at 9:46 am - Reply

    Teniendo en cuenta que un escaner Canon Lide 30 es propio para una utilizacion domestica en donde sus propietarios aspiran al adquirir nuevos PC´s con W7 con 64 que Canon proporcione los correspondientes “drivers”..Pues NO!!!. Aqui aparecen infinidad de fracasos al intentar acoplar este escaner al W7. Canon incomprensiblemente ha decidido una politica nula de atencion con sus clientes. Manifiesto mi decepcion con Canon ,con memoria de este fiasco al retirarle mi confianza en la adquision de un nuevo producto producto en que este presente.

  17. valey February 27, 2013 at 8:57 pm - Reply

    that realy work!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!!! follow that steps and done!

    • unlimited April 15, 2013 at 4:42 pm - Reply

      Free download canon canoscan lide 110 scanner driver software

  18. Kenneth L. Edvardsen March 26, 2013 at 9:25 pm - Reply

    Awesome it works! I’ve been looking for a solution a long time, finally I found it. Thank you :-)

  19. Mr C May 18, 2013 at 5:01 pm - Reply

    With a bit of work the Canon scanner works in W7 32 bit without issues. 64 bit is another problem altogether. A workaround I found (only works in Windows 7 Pro, Ultimate & Enterprise) was to set up XP mode (http://windows.microsoft.com/en-GB/windows7/products/features/windows-xp-mode), attach the scanner (USB devices in the XP mode menu), install the Canon software and 32 bit Windows XP driver and close down XP mode.

    In Windows 7 you can run the Canon toolbox in XP mode without having to load the entire XP operating system. This gives you the XP interface but most importantly, it works!

    Hope this helps.

  20. Bianco Ciro May 16, 2014 at 1:49 am - Reply

    Hi, have you solved the problem of LiDe30 on Win7-x64 ?

    • Geckoandfly May 16, 2014 at 2:53 am - Reply

      yes, it is shown in the tutorial. but some people complain this doesn’t work. maybe it is the SP1 update.

Leave a Reply

Your email address will not be published. Required fields are marked *

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>